Erfahrungen mit meiner 1. MX Linux Installation auf Uefi native und nvme

Hier dokumentiere ich mal meine Installationshistorie:

Soeben MX Linux MX-19.4.1_ahs_x64 neben Artix installiert.

Die nvme Partitionen wurden alle erkannt.
Die esp Partition wurde nicht erkannt.
Entsprechend wurde sie auch nicht zum Installieren von grub angeboten.
Die esp liegt auf Festplatte 1 auf der 1. Partition (nvme0n1)

Als Optionen für grubinstall standen nur MBR und PBR zur Verfügung. Esp war ausgegraut.

Ich wählte dann die Partition / für grub. (nvme0n1p4)

mx1:[me]:~$ lsblk
NAME        MAJ:MIN RM   SIZE RO TYPE MOUNTPOINTS
nvme1n1     259:0    0 465,8G  0 disk 
├─nvme1n1p1 259:3    0   8,4G  0 part [SWAP]
├─nvme1n1p2 259:5    0 150,9G  0 part 
├─nvme1n1p3 259:7    0  79,7G  0 part 
└─nvme1n1p4 259:9    0  99,3G  0 part 
nvme0n1     259:1    0 232,9G  0 disk 
├─nvme0n1p1 259:2    0   250M  0 part /boot/efi
├─nvme0n1p2 259:4    0  30,3G  0 part /
├─nvme0n1p3 259:6    0  50,8G  0 part /home
├─nvme0n1p4 259:8    0  28,2G  0 part /run/media/me/rootMX19
└─nvme0n1p5 259:10   0  49,8G  0 part /run/media/me/homeMX

Dies mal bis hierher.

Nebenbei noch ein absoluter Hammer, den ich entdeckte.

Ich schaute vorsorglich nochmal ins Bios und checkte, ob alle Einstellungen korrekt sind.
Und siehe da. Es war secureboot aktiviert!!
Der Laptop war ja in Reparatur. Die Aktivierung von secureboot kann also nur durch den Techniker vorgenommen worden sein. Von alleine verstellt sich das doch bestimmt nicht.

Das geht gar nicht. Ich habe mich soeben auch bei Schenker beschwert.

Von einem Techniker erwarte ich, dass er auch ein bisschen über Linux bescheid weiß. Sprich weiß, dass bei vielen Linux Distributionen secureboot deaktiviert sein muss!
Wenn Bioseinstellungen geändert wurden und auf dem RMA ausdrücklich vermerkt war, dass der Kunde Linux nutzt, dann müssen die original Bisoeinstellungen wieder hergestellt werden.
Hinzu kommt noch, dass ich sogar extra mit Ausrufezeichen auf den RMA schreib, dass kein Windows installiert werden darf. Ok, wurde zwar nicht gemacht, aber trotzdem ein weiterer Hinweis bezüglich secureboot. Sprich, dass man ohne Windows auf dem System secureboot nicht benötigt.

Ich frage mich, warum die secureboot überhaupt aktivieren müssen. Haben die nur Microsoft Diagnosetools und brauchen die dann überhaupt secureboot, bzw. müssen womöglich sogar Win temporär installieren?
Ich dachte Diganosetools sind Livesysteme, die nur das Ram brauchen?

Zum Thema esp nicht erkannt:

Ich habe ein bisschen recherchiert.
Ich meine mich zu erinnern, dass bei der Artix Installation die esp nur mit boot flag angeboten wurde. esp konnte man nicht wählen. Ich kann mich irren, aber das ist jetzt erst mal egal.
Die Partition ist ja vorhanden und funktioniert.

Nun habe ich im MX Forum gelesen. Soweit ich es verstanden habe, muss zur Erkennung der esp, diese als esp geflagt sein?
https://forum.mxlinux.org/viewtopic.php?p=639411#p639411

ESP partition has both boot (and) esp flags (GParted on live-session)

Die esp ist als msftdata geflagt

mx1:[me]:~$ sudo parted -l
Partitionstabelle: gpt
Disk-Flags: 

Nummer  Anfang  Ende    Größe   Dateisystem  Name  Flags
 1      1049kB  263MB   262MB   fat32              msftdata
 2      263MB   32,8GB  32,5GB  ext4
 3      32,8GB  87,3GB  54,5GB  ext4
 4      87,3GB  118GB   30,3GB  ext4
 5      118GB   171GB   53,5GB  ext4

Daherziehe ich den Schluss, dass der Installer das nicht erkennt.

Teil 2 der Installation:

Ich habe MX nochmals neu installiert, aber ohne grub.
Mein Gedanke war, ich lasse MX vom grub der /boot/efi erkennen und ins grubmenü einfügen.

Sehe ich das richtig, dass ich das mit os-proper, bzw. grub-mkconfig mache?
MX müsste dann erkannt und ins grubmenü geschrieben werden ?

Die Partition wo MX drauf ist muss gemountet sein und dann folgendes ausführen?

sudo grub-mkconfig -o /boot/grub/grub.cfg

https://wiki.archlinux.org/title/GRUB#Detecting_other_operating_systems
Der Eintrag GRUB_DISABLE_OS_PROBER=false ist weder in grub, noch in grub.cfg

Oder bin ich da total auf dem Holzweg?

Hallo Thats_me,
wenn ich so sehe, welche Probleme Du nicht nur hier, sondern auch in einem anderen Thread mit UEFI hast, kann ich nur sagen, Augen auf beim Computerkauf :wink:
Zum Thema: Normalerweise erkennt MX bei der Installation ESP und richtet danach alles ein. Auch die MX-Bootreparatur bietet ja an, ob Grub ins ESP, MBR oder PBR soll.
zur Vorbeugung: das soll nun nicht heissen, ich glaube dir nicht, sondern nur, dass dies für mich Theorie bleibt, da ich solchen Unsinn wie UEFI nicht an meinen Rechner lasse und kann es nicht nachbauen.

Ja, kannst Du machen, aber ich bin da immer vorsichtiger und lasse die grub.cfg immer erstmal woanders hin schreiben um sie mir ansehen zu können, also z.B.
sudo grub-mkconfig -o /home/gv/grub.cfg
oder wo immer Du hinmöchtest. Wenn Du die dann in Augenschein genommen hast und für gut befunden, kann sie immer noch nach /boot/grub/
Oder die andere Möglichkeit, vorher Sicherung von /boot/grub/grub.cfg
Aber da Du wohl tapferer bist als ich geht einfach drüberbügeln auch.

Deshalb steht in der Anleitung das kleine Wörtchen „add“ :wink:
edit /etc/default/grub and add/uncomment

viele Grüße gosia

Hi gosia,

Welchen meinst du?

Ich stehe ja auch nicht so auf Uefi. Darum achtete ich beim Kauf darauf, dass dieses Bios auch legacy Modus hat. Das hatte der Clevo (den ich m 8.03. zurückschickte und noch immer auf mein Geld warte) nämlich nicht.
Da ich aber neugierig bin und Linux auch auf Uefi funktioniert, probierte ich das halt aus.
Bis jetzt lief ja alles super.

Richtig, normalerweise. Bei mir halt mal wieder nicht (wie sollte es auch anders sein :frowning: ) .
Ich verstehe das ja auch nicht.
Im MX Forum (link s. o.), kann auch ein anderer User grub nicht auf die Efi Partition (bzw. nvme) installieren.

When it came time to install grub, the default partition in the pull down was the installer USB drive /dev/sda?, not the nvme device. The radio button was set to ESP, which is correct, but the partition drop down only had a single choice, a partition on the sda device.

Nur mit dem Unterschied, dass bei mir esp ausgegraut war. Und dem weiteren Unterschied, dass ich alle bestehenden nvme Partitionen wo Artix drauf ist auswählen konnte. Das wäre dann nach meinem Verständnis aber einer Installation in den PBR gleich gekommen.

Es gab wohl schon früher Probleme mit dem flag. Auch dies spricht dafür, dass die esp als esp, oder zumindest boot geflagt sein muss? die esp partition habe ich als bootable bei der Installation von Artix auch angeklickt. Da bin ich mir absolut sicher.

https://forum.mxlinux.org/viewtopic.php?p=566721#p566721

occassionaly the ESP, boot flag doesn’t get set on EFI partitions. I thought we fixed this on the installer version on MX19.1, but it still occasionally happens, usually on systems with the SATA configuration not quite meshing with the nvme drive (at least that’s what I think happens).

you can set the flag manually with gparted, and then use mx-boot-repair to reinstall grub to the ESP.

Ich möchte die /boot/efi aber nicht nachträglich auf esp setzen. Das ist mir zu heikel. Keine Ahnung, ob Artix dann ohne Zutun bootet. Im Uefi bootmanager steht das OS zwar in der Option „nvme drive“ drin,


mx1:[me]:~$ efibootmgr -v
BootCurrent: 0001
Timeout: 1 seconds
BootOrder: 0001
Boot0001* UEFI OS	HD(1,GPT,6a060eb0-ae4f-9247-8ea6-32d3c26b1cf0,0x800,0x7d000)/File(\EFI\BOOT\BOOTX64.EFI)..BO

aber bevor ich mir da Stress einhandle, mache ich das lieber über grub-mkconfig
Das scheint mir die elegantere Methode zu sein.

Ich habe mir die grub.cfg gesichert. Mehrfach, also auch auf einen Stick, falls ich wider Erwarten im Notfall per chroot nicht auf meine anderen Partitionen komme. Also sogar total panisch vorsichtig. :flushed:

Grrr, dieses uncomment bedeutet ja, den # zu entfernen. Das war ein Denkfehler von mir. Ich dachte man soll es auskommentieren = # rein machen.
Ok, dann schreibe ich also GRUB_DISABLE_OS_PROBER=false in /etc/default/grub

Muss das an eine bestimmte Stelle in Grub, oder ist das egal?

Hallo Thats_me,

ich habe bei Installationen von MX Linux die Erfahrung gemacht, dass man vorher die Festplatte immer formatieren sollte.
Ich lege über gparted die erste Partition mit 512 MB als fat32 (für UEFI) an. Auf jeden Fall muss man die Markierung dieser Partition auf boot, esp stellen.
Danach die anderen Partitionen wie gewöhnlich (root, home und swap) und dann klappt bei mir auch die Installation.

Gruß
Roberto

Jo, das habe ich vor der Installation von Artix auch gemacht und der esp vorsorglich auch mehr als 100 MB spendiert. (262 MB)

Das Ding ist, dass die esp mit fat32 ja schon exisitert und sie als mfsdata geflagt wurde.
Warum weiß ich nicht, denn ich habe das definitiv bei der Installation nicht ausgewählt. Nur bootable, da esp meiner Erinnerung vom Artix-Installer nicht zur Auswahl angeboten wurde.
Oder ich habe es übersehen?

https://mxlinux.org/wiki/system/uefi/#64bit
Ich fette mal

Then go to Manage Flags and select ‘boot’ andesp’ (‘esp’ should be selected by default when you select ‘boot’). The EFI System Partition (ESP) will be created as sda1 and will store boot code for each OS in use going forward.

Das esp flag fehlt bei mir. Und sda habe ich auch nicht. Sondern nvme.

Ich könnte mal die SATA Einstellungen im Bios checken. Nur weiß ich ehrlich gesagt nicht auf was die stehen müssen.

Das ist bei mir auch, wenn ich a) von einer Artix Installation komme und b) wenn man mit geparted neu formatiert hat.
Deswegen muss man die Markierung nachträglich auf boot, esp aändern.

Danke Roberto aber das kapiere ich nicht.

Was meinst du mit von einer Artix Instalaltion komme?

und b) wenn man mit geparted neu formatiert hat.
Deswegen muss man die Markierung nachträglich auf boot, esp aändern.

Ach jetzt macht es klick. Ich habe nach dem Erstellen der esp vergessen gleich in Gparted das esp flag zu setzen und nur boot gesetzt. Stimmt. * andistirnklatsch. *
Aber das mfsdata habe ich definitiv nicht aktiviert. Da hätte ich gar nicht gewusst was das ist.
Hat das dann Gparted gemacht? Wo kommt diese Bezeichnung her?

Kann ich das nachträglich noch gefahrlos machen? Startet dann Artix trotzdem noch?
Das Verzeichnis /boot/efi wird davon ja nicht tangiert?

Wenn ich auf eine bereits mit Artix installierte MX installieren möchte, wird mir die Boot Partition mit der Markierung mfsdata angezeigt.

Ok.
Dann machte das also MX?
Hast du eine Erklärung, warum ich grub nicht in die esp installieren konnte, bzw. diese Partition nicht für grub angeboten wurde?

Ich frage mal im MX Forum nach. Das interessiert mich nämlich.

EDIT:
Noch was seltsames. fdisk spuckt das hier aus:

Gerät             Anfang      Ende  Sektoren Größe Typ
/dev/nvme0n1p1      2048    514047    512000  250M Microsoft Basisdaten
/dev/nvme0n1p2    514048  64002047  63488000 30,3G Linux-Dateisystem
/dev/nvme0n1p3  64002048 170498047 106496000 50,8G Linux-Dateisystem
/dev/nvme0n1p4 170498048 229627903  59129856 28,2G Linux root (x86)
/dev/nvme0n1p5 229627904 334170111 104542208 49,8G Linux root (x86)

Woher bitte kommt Microsoft Basisdaten?
Auf diesem Rechner war noch nie MS drauf.
Und die nvme0n1p1 habe ich selbst angelegt, als Fat 32.

Hallo Thats_me,

angeboten wird es schon. Könnte sein, dass es ausgegraut wurde, weil die Partition kein esp-Flag hatte und das braucht es für UEFI schon. Womit wir wieder am Anfang wären…
Ohne esp-Flag kann die arme Installationsroutine ja wohl nicht wissen, dass es esp gibt, ergo, wo vermeintlich nix ist, kann auch nix angeboten werden.

Was mfsdata sein soll weiss ich auch nicht. Habe ich noch nie gesehen. Aber bei mir ist es umgekehrt, mein Grub kommt von MX und Artix hat keinen…

viele Grüße gosia

Danke gosia.

Artix hatte damit aber kein Problem. Es wurde ja problemlos installiert und erscheint auch im Bios.

Bei mir sollte es msfdata heißen, kleiner Tippfehler :frowning:

Du hattest doch keinen Tippfehler. Selbst wenn, wäre schon klar gewesen, was gemeint ist.

Bei mir ja auch. Ich wusste nur nicht, wo das her kommt.

EDIT:
So oder so, wie gehe ich jetzt am besten vor?
Artix hat ja kein Problem mit dem fehlenden esp flag.

Und mit grub- mkconfig müsste MX dann ja in grub implementiert werden?

Bei MX sieht es so aus:

Hallo Thats_me,

Das sieht nach GPT-Partitionierung aus

aber genaueres könnte man wohl nur sagen, wenn du mal z.B. die Ausgabe von
fdisk -l
postest.

Ja, ja, ja. „mit Windows hat das aber funktioniert…“ :wink:
kann ja sein, Artix ist eben Artix und MX ist MX. Aber letzendlich weiss ich es doch auch nicht. Ich arme Socke muss ohne UEFI auskommen und alles was ich dazu sagen kann ist graue Theorie.
Ich habe nur gelesen, im BIOS sollte Fast- und Secure-Boot aus sein, Native UEFI ON bzw. der BIOS compatibility Modus aus. Aber das hast Du ja selbst schon gelesen.
Aber es geht hier so schnell voran, dass ich langsam nicht mehr weiss, was dein endgültiger Plan ist → MX von Artix aus booten oder Artix von MX aus booten?
Ich hatte beide Varianten mal gehabt, ging beides.

da wiederhole ich mich mal: Sieh es dir vorher an, dann weisst Du es. Aber meine Antwort ist JA

viele Grüße gosia

PS. Irgendwo war mal die Frage, wo der GRUB_DISABLE_OS_PROBER hin muss. Wenn es noch nicht geklärt ist sage ich mal ganz kühn, schreib es als letzte Zeile hin.

1 Like

Danke gosia

Das ist mir schnuppe. Würde das einen großen Unterschied machen?
Außer dem hier: Dual boot Arch Linux with another Linux (os-prober) | Average Linux User

Unfortunately, the setup of several Linux systems with one bootloader requires that you need to mount all the secondary systems and update GRUB manually every time you update your kernel. If your secondary systems are mounted during the update of Arch Linux, then the manual update is not necessary. Also, if you cannot find your secondary system in the GRUB menu after updating, this means that you forget to manually update GRUB. Boot in your Arch Linux, mount the second system and update GRUB.

Beim Start kommt ja eh das grub und bietet mir an, was ich booten will.
Und MX habe ich nun ja ohne grub installiert.

Es wäre ja kein Problem das esp flag nachträglich zu setzen und MX nochmal zu installieren.
Nur weiß ich nicht, wie Artix sich dann verhält, wenn ich nachträglich mit esp + boot markiere.

Super, danke. Das mache ich jetzt sofort.

EDIT:

Verstehe ich nicht.
Windows war noch nie auf diesem Laptop.

So, Thema erledigt.

Ich habe einfach MX ins Grub schreiben lassen.
Es bootet, Update habe ich auch gleich gemacht.

Nur spinnt Artix inzwischen ein bisschen rum. Nach dem Anmelden kommt jetzt immer ein blackscreen mit blinkendem cursor. Dann dauert es eine Weile und der Desktop erscheint.

Hallo Thats_me,
ich habe am Anfang MX von Artix aus gebootet, also den Artix-Grub benutzt. Einfach deshalb, weil Artix zuerst da war und MX erst später installiert wurde. Kein Problem. Später habe ich das dann umgedreht (weiss nicht mehr warum), geht auch.
Da Du nun MX ohne Grub installiert hast, na dann probiere einfach aus, ob es auch funktioniert.

Würde ich nur machen, wenn das booten von Artix aus nicht funktioniert. Aber wenn, dann kann ich mir nicht vorstellen dass sich Artix durch so ein dussliges esp-Flag iritieren lässt. Aber wie gesagt, keine praktische Erfahrung.

Die Ironie war wohl zu dick aufgetragen. Ich hätte auch schreiben können „mit Ubuntu hat das aber funktioniert…“ :wink: und ja, weder Windows noch Ubuntu war jemals auf deinem Rechner. Du darfst nur die nachfolgende Sentenz nicht überlesen

das zielte mehr auf die in Foren zu oft gelesene Formulierung ab „in meiner alten FOO-Distri hat das aber auch funktioniert, warum kann ich das in der BAR-Distri nicht auch so machen???“ Manches ist eben verschieden.
Wie gesagt, für mich nur Theorie, aber wenn die bei MX schreiben, man soll das esp-Flag setzen, so machen die das bestimmt nicht aus Langeweile. Vielleicht lösen die bei Artix das irgendwie anders. Aber vergiss es einfach…

viele Grüße gosia

1 Like