Artix Xfce Energieoptionen - Screensaver und Bildschirmenergieverwaltung

Huhu @all,

bevor das Forum dicht macht, plage ich euch nochmal mit einem kleinen Problem und freue mich über Hilfe.

Weder die Einstellung „Schwarzer Bildschirm nach x Minuten“ noch der screensaver funktioneren.

Es scheint daran zu liegen, dass DMPS deaktiviert ist.
apps:xfce4-screensaver:faq [Xfce Docs]

Why doesn’t my monitor turn off automatically?

Display Power Management Signaling (DPMS) has been disabled by another application.

xmg:[me]:~$ xfce4-screensaver

** (xfce4-screensaver:8820): WARNING **: 13:33:11.848: Bildschirmschoner läuft bereits in dieser Sitzung
xmg:[me]:~$ xdg-screensaver status
enabled
xmg:[me]:~$ xset -q
Keyboard Control:
  auto repeat:  on    key click percent:  0    LED mask:  00000002
  XKB indicators:
    00: Caps Lock:   off    01: Num Lock:    on     02: Scroll Lock: off
    03: Compose:     off    04: Kana:        off    05: Sleep:       off
    06: Suspend:     off    07: Mute:        off    08: Misc:        off
    09: Mail:        off    10: Charging:    off    11: Shift Lock:  off
    12: Group 2:     off    13: Mouse Keys:  off
  auto repeat delay:  500    repeat rate:  20
  auto repeating keys:  00ffffffdffffbbf
                        fadfffefffedffff
                        9fffffffffffffff
                        fff7ffffffffffff
  bell percent:  50    bell pitch:  400    bell duration:  100
Pointer Control:
  acceleration:  2/1    threshold:  4
Screen Saver:
  prefer blanking:  no    allow exposures:  no
  timeout:  60    cycle:  60
Colors:
  default colormap:  0x20    BlackPixel:  0x0    WhitePixel:  0xffffff
Font Path:
  built-ins
DPMS (Energy Star):
  Standby: 300    Suspend: 0    Off: 360
  DPMS is Disabled
xmg:[me]:~$

DPMS – wiki.archlinux.de
Ab Xorg 1.8 wird DPMS automatisch geladen und zugelassen, sofern ACPI-Module geladen werden.
Da die xorg.conf nicht mehr verwendet wird, werden die folgenden Einstellungen in einer Datei im Verzeichnis /etc/X11/xorg.conf.d gesetzt - in diesem Falle bietet sich die 10-monitor.conf an.

Das ist bei mir nicht der Fall und die 10-monitor.conf gibt es dort nicht.
Darum helfen mir auch die dort empfohlenen Eintragungen nichts.

Wo bekomme ich diese 10-monitor.conf her? Im Netz habe ich zwar verschiedene Ausschnitte dieser Datei gefunden, bin mir jedoch nicht sicher, ob das jeweils die komplette Datei war.
Wo finde ich eine „Originaldatei“, bzw. was muss da alles rein?

Thx TM

Wenn es eine .conf Datei nicht gibt, dann muss man diese selbst anlegen in dem entsprechenden Ordner.


EDIT:
Das ist genauso was. Warum ist das nicht installiert und konfiguriert bei Artix?

Das verstehe ich nicht

Eben :wink:

Wenn ich aber nicht weiß wie so eine Originaldatei, oder Musterdatei aussieht, kann ich sie auch nicht in das Verzeichnis kopieren.

Das ist genauso was. Warum ist das nicht installiert und konfiguriert bei Artix?

Stimmt. Also ich habe sehr sehr viel nachinstallieren und anpassen müssen bisher.
Ich habe das zum Glück einigermaßen dokumentiert. Wenn ich das System mal neu aufsetzen muss, ist das echt eine Menge Arbeit :frowning:
Aber sonst bin ich bis jetzt sehr zufrieden.
Jedenfalls wesentlich weniger Probleme als mit Manjaro.

Welche empfohlenen Einstellungen?
Nimm doch die, lege die Datei an, und schaue was passiert.

Es gibt doch aber auch noch das Programm xfscreensaver, oder?

Welche soll ich nehmen? Ich habe doch keine Ahnung, was ich da alles rein schreiben muss.
Kann bei Artix ja alles wieder total anders sein, als bei Arch oder Standard.

Ich habe bisher folgende „Muster“ gefunden:

Section "Monitor"
    Identifier             "Monitor0"
EndSection

Section "Device"
    Identifier             "Device0"
    Driver                 "vesa" #Choose the driver used for this monitor
EndSection

Section "Screen"
    Identifier             "Screen0"  #Collapse Monitor and Device section to Screen section
    Device                 "Device0"
    Monitor                "Monitor0"
    DefaultDepth           16 #Choose the depth (16||24)
    SubSection             "Display"
        Depth              16
        Modes               "1440x900_60.00"
    EndSubSection
EndSection

Und so eine

## /etc/X11/xorg.conf.d
Section "Monitor"
	Identifier	"eDP1"
	Option		"Primary" "true"
	Option		"PreferredMode" "1920x1080_60.05"
EndSection

Section "Monitor"
	Identifier	"DP2"
	Option		"LeftOf" "eDP1"
	Option		"PreferredMode" "1366x768_59.79"
EndSection

Bei gentoo findet man ja auch manchmal Tipps, ist mir aber unklar, ob die übertragbar sind.
Dort gibt nur eine ganz kurze 20-Monitor.conf

Ich dachte es geht um den Bildschirmschoner und die Energieeinstellungen?
Ich bin jetzt verwirrt.

Was ist mit dem Programm xfce-screensaver und/oder xfce-powermanager? Das macht doch das was du willst.
Hast du die xfce-goodies nicht installiert?

Ja, aber die funktionieren halt nicht. Bei meiner Recherche stieß ich auf obige, mögliche Ursachen und hangelte mich dann so durch. Keine Ahnung, ob ich richtig liege.

Was ist mit dem Programm xfce-screensaver und/oder xfce-powermanager?

Beide installiert.

Das macht doch das was du willst.

Leider nicht.

Hast du die xfce-goodies nicht installiert?

Nunja, das gibt es ja nicht als Gesamtpaket, daher weiß ich nicht, was da alles dazu gehört.

Ich habe die einzelnen Pakete installiert, die ich brauche.

Achso, ok, jetzt habe ich es verstanden.

Ich habe kein XFCE, daher muss ich jetzt passen, sorry.

Das die keine xfce-goodies haben passt ja mal wieder zu Artix. Wobei da halt auch viele Sachen drin sind die man nicht braucht.

So ist es.

Wobei ich das Grundprinzip von Artix und Arch ja so verstanden habe, dass genau das so gewünscht ist. Dass nur das absolute Minimum in der Grundinstallation ist und man alles andere extra dazu installieren muss.

Daher wunderte ich mich ja so,

Grundansatz von Linux habe ich offenbar total missverstanden

dass bei einem Update manchmal irre viele Pakete mit, bzw. nachträglich dazu installiert werden.

Das kann halt sein, wenn ein Programm eine neue Version einer Lib benutzt oder generell eine andere/neue Lib benutzt. Und je nachdem was die für Abhängigkeiten haben, können halt noch Sachen dazu kommen.

Habe gerade mal nachgesehen, hast recht, bei Arch gibt es auch kein xfce-goodies.
Weiß gar nicht mehr wo es das gibt.

Hallo daemon,

Oh, langsam, bitte keine voreiligen Schlüsse. Die gibt es schon, nur die Organisation ist etwas anders (Stichwort „Gruppen“) und dann heissen die leicht anders → xfce4-goodies

sudo pacman -S xfce4-goodies
:: Es gibt 37 Elemente in Gruppe xfce4-goodies:
:: Repositorium world
   1) mousepad  2) ristretto  3) thunar-archive-plugin  4) thunar-media-tags-plugin  5) xfburn  6) xfce4-artwork  7) xfce4-battery-plugin
   8) xfce4-clipman-plugin  9) xfce4-cpufreq-plugin  10) xfce4-cpugraph-plugin  11) xfce4-datetime-plugin  12) xfce4-dict  13) xfce4-diskperf-plugin
   14) xfce4-eyes-plugin  15) xfce4-fsguard-plugin  16) xfce4-genmon-plugin  17) xfce4-mailwatch-plugin  18) xfce4-mount-plugin  19) xfce4-mpc-plugin
   20) xfce4-netload-plugin  21) xfce4-notes-plugin  22) xfce4-notifyd  23) xfce4-pulseaudio-plugin  24) xfce4-screensaver  25) xfce4-screenshooter
   26) xfce4-sensors-plugin  27) xfce4-smartbookmark-plugin  28) xfce4-systemload-plugin  29) xfce4-taskmanager  30) xfce4-time-out-plugin
   31) xfce4-timer-plugin  32) xfce4-verve-plugin  33) xfce4-wavelan-plugin  34) xfce4-weather-plugin  35) xfce4-xkb-plugin
:: Repositorium galaxy
   36) parole  37) xfce4-whiskermenu-plugin

Geben Sie eine Auswahl ein (Voreinstellung=alle)

und das Konzept finde ich gar nicht so schlecht. Schliesslich will ich nicht gezwungen sein, den ganzen Klumpatsch zu installieren, sonden kann auswählen, was ich wirklich möchte.

viele Grüße gosia

PS. Ach so, eine XY-monitor.conf habe ich auch nicht und trotzdem funktioniert mein Screensaver wie gewünscht.

Ich konnte zu dem Zeitpunkt, als ich dies geschrieben habe, nicht nachschauen. Dass das eine Gruppe ist hatte ich vergessen, obwohl ich weiß das es kein einzelnes Paket ist.
Und das ich xfce-goodies geschrieben habe anstatt xfce4-goodies ist ja egal, man wusste ja was ich meine.

@Thats_me und ich haben beide fast den gleichen Laptop, und jeder hat Probleme, auch wenn diese unterschiedlich sind.
Ich glaube mittlerweile dass die gar nicht testen auf neuen Geräten.

Hallo daemon,

Kein Problem.
Außerdem hilft meine Bemerkung, dass es bei mir funktioniert, Thats_me auch nicht so richtig weiter. Aber manchmal verstehe ich die Welt nicht mehr

warum ist bei mir so vieles anders???

Screen Saver:
  prefer blanking:  no    allow exposures:  no
  timeout:  300    cycle:  300
Colors:
  default colormap:  0x20    BlackPixel:  0x0    WhitePixel:  0xffffff
Font Path:
  built-ins
DPMS (Energy Star):
  Standby: 600    Suspend: 0    Off: 900
  DPMS is Enabled
  Monitor is On
[/quote]

DPMS ist Enabled ohne dass ich mich irgendwie drum gekümmert habe, weder aktiv ACPI-Module geladen, noch irgendwie eine monitor.conf gebastelt oder eingefügt. Liegt das nur an meinem anderen Laptop?

Naja, die Artix-Entwickler können ja unmöglich auf allen Geräten testen.

viele Grüße gosia

Da gebe ich dir recht.
Aber wenn ich dann gefragt werde ob ich wirklich zwei GPUs im Laptop habe, dann frage ich mich, in welchem Jahr die leben. Gut, es waren nicht die Entwickler, aber anscheinend sind auch manche User bei denen im Forum in der Zeit stehen geblieben.
Ist ja nicht so als ob es das erst seit gestern gibt.

Und wie man sieht, ist @Thats_me nicht die einzige Person mit Problemen.
Also irgendwas läuft da mit neuer Hardware und Artix nicht ganz rund.

Zwei GPUs ist wirklich ein alter Hut, seit Intel eine integrierte Grafik hat, wurde in der Regel eine dedizierte Nvidia dazu eingebaut. Bestimmt schon seit über 10 Jahren.

Aber das eine integrierte AMD-GPU und eine dedizierte Nvidia-GPU gleichzeitig verbaut werden, verbreitet sich erst seit dem Erfolg vom AMD-Ryzen immer mehr. Das sollten natürlich Entwickler wissen.

Dann gibt es noch den Intel oder AMD-Code der beim booten geladen wird. Eventuell noch eine extra Firmware die gebraucht wird.

Hinzu kommt, das die Nvidia-Driver unter Linux oft mieserabel sind, selbst der freie Treiber, weil Nvidia keine Infos raus rückt.

Und getestet wird in der Regel wirklich nur noch sehr wenig, selbst bei code der nur wenig geändert wird, darüber habe ich mich auch schon oft geärgert. Ganz Allgemein bei jeder Software. Weil es immer wieder bugs gibt, die jeder maintainer/Entwickler sofort sehen würde, wenn Er:Sie:Es:Umoperierte ihr Machwerk auch nur 1x starten würden.

Moin gosia,

Diese Frage kenne ich gut :wink: Wie oft hatte ich schon Probleme, weil bei mir etwas war, das eigentlich nicht sein kann.

Ausgehend davon, dass meine Vermutung und Herleitung dass es was mit dpms zu tun hat korrekt ist, habe ich folgendes gemacht:

xmg:[me]:~$ xset +dpms
xmg:[me]:~$ xset -q
DPMS (Energy Star):
  Standby: 300    Suspend: 0    Off: 360
  DPMS is Enabled
  Monitor is On
xmg:[me]:~$ xfce4-screensaver

** (xfce4-screensaver:5228): WARNING **: 11:26:03.630: Bildschirmschoner läuft bereits in dieser Sitzung
xmg:[me]:~$ xdg-screensaver status
disabled

Energieoptionen → Bildschirm → schwarzer Bildschirm → nach 1 Minute
1,5 Minuten gewartet → Bildschirm müsste nach 1 Minute schwarz werden. →
→ nichts passiert.

Aber:
Ich checkte nochmal die Einstellungen des Bildschirmschoners.
Dann kam folgende Meldung:

Scheinbar läuft der XScreenSaver-Dienst nicht für die Anzeige >>:0.0<<
Soll er jetzt gestartet werden?
→ JA.
Und siehe da, zumindest der Bildschirmschoner funktioniert.

Was ich nicht kapiere, laut Terminal lief der screensaver doch. Oder ist der „XScreensaver“ was anderes als der „xfce4-screensaver“ und warum?

Nun stellt sich mir auch ganz allgemein die Frage.
Wenn der Bildschirmschoner installiert ist und ich dort Einstellungen vornehme gehe ich davon aus, dass der Dienst dann auch automatisch gestartet wird und ich den nicht manuell starten muss.

Da fehlt mir anscheinend mal wieder ein gewisses Grundverständnis der Prozesse.

Oder ist das bei openRC anders und man muss fast jeden Dienst manuell hinzufügen?
Wie z. B. bei cups, da dachte ich auch, wenn ich den Drucker aufrufe startet cups. Dabei musste ich den Dienst erst hinzufügen, damit er automatisch startet.
Also immer wenn etwas nicht startet, den Dienst hinzufügen? Aber dann startet er ja schon beim booten?
Das kann’s ja nicht sein. Die meisten Dienste brauche ich doch erst beim Aufruf der Anwendung.

Was verstehe ich da schon wieder nicht, bzw. falsch?

Das glaube ich nicht, denn bei mir unter KDE funktioniert das mit dem Bildschirmschoner. Ich habe den nur aus gemacht bzw. bei mir geht der Laptop erst in den Sperrbildschirm, und dann wird er schwarz.

Bei @gosia funktioniert es ja auch ohne etwas gemacht zu haben.

Deswegen sagte ich ja, irgendwas stimmt nicht mit Artix. Kann ja nicht sein das es mal so und mal so ist.

Dann würde mir nur noch einfallen, dass es evt. damit zusammenhängt, welche Programme, Pakete man installiert hat.

Sinngemäß so wie bei Firefox die Addons, die sich manchmal gegenseitig beeinflussen und dann manches nicht mehr funktioniert.

Wenn ich erinnere, wie viele zusätzliche Pakete teilweise bei einem Update nachinstalliert werden, entsteht dann ja schon ein recht aufgeblähtes System.

EDIT:
Kann mir jemand erklären, was diese zusätzlichen Energieoptionen im Bildschirmschoner bedeuten? vielleicht ist sich ja da etwas im Gehege. Dürfte aber nicht sein, da ja beides von xfce ist und keine „Fremdanwendung“.
Den Zusammenhang von xdg und xfce habe ich auch noch nicht verstanden. Da scheint es einen zu geben.

Doch, „XScreensaver“ ist ein vollkommen unabhängiger Bildschirmschoner, mit dem man viel bling bling einstellen kann. Z.B. wechselnde Bilder oder sogar ein Video abspielen lassen. Finde ich vom Energie sparen zwar sinnfrei, aber manche finden so was toll.
Jedenfalls ist der neutral und den kann man in vielen Desktop-Umgebungen oder Window-Manager nutzen.

Ein Minimalistischer Screenserver ist unter Energiespar-Optionen im Xfce4 schon drin. Hast Du ja konfiguriert.

Scheinbar kommen die sich tatsächlich in die Quere, könnte an Wayland liegen. Damals nur mit xorg hatten wir nicht so viele Probleme, gilt auch für das backlight, das funktioniert selbst auf meinem Lenovo mit neueren Live-Medien auch nicht mehr vernünftig. Aber auch der Grafiktreiber kann neben dem Kernel eine Rolle spielen.

Danke @virtual-dev

Bildschirmschoner brauche ich nicht. Ich bevorzuge, den Bildschirm nach gewisser Zeit einfach schwarz zu machen. Das Gezappele auf dem Bildschirm nervt mich eher. Das funktioniert ja leider nicht und ich habe keine Idee, woran es liegt.
Ich deinstalliere den einfach mal, vielleicht hilft das.

Schwärzen kann ich zwar auch manuell über die Fn Taste, aber manchmal gehe ich nur kurz weg, es dauert dann aber länger als geplant. Dann ist es praktisch, wenn der Bildschirm trotzdem schwarz wird.

Ich lasse den Rechner oft durchlaufen. Z. B, wenn ich weiß ich komme in 1 Std eh wieder
Ist zwar nicht sehr „Öko“ und Energieverschwendung, aber dafür spare ich anderweitig viel Energie. Ich verbrauche pro Jahr nur 1100 bis 1300 kWh.

Häufiges An- und Ausschalten ist für die Geräte bestimmt auch nicht so toll.